Wireless Woes

It was always my intention when I had my workshop/shack installed to install a permanent wired network link, however I never did and now it would prove a logistical nightmare.

When I first got wired up to the Internet with Diamond Cable back in the late 1990s it was via a second telephone line fed in to the ‘computer room/study’ which in reality was the small ‘box/bedroom’ at the front of the house.

Diamond Cable became NTL/VirginMedia and with the introduction of proper broadband the Cable Modem naturally got installed in the same front bedroom. I have always had several computers networked together but mostly in the same room via cables.

I eventually got a router with wireless capabilities the ubiquitous Linksys WRT54G and gradually more and more devices have been linked wirelessly. Laptops, smart-phones, a modified original X-Box running XBMC to play videos on the TV, Netgear MP-101 media player and a Nintendo Wii. More recently my new Canon printer and Samsung SmartTV are now connected to the wireless network.

Over the years I have acquired different routers and access points but I kept going back to the WRT54G as it didn’t have as many compatibility issues and since the firmware was upgraded to Tomato and has proved to be rock solid. It covers the house reasonably well, but not so well at reaching the shack in the back garden, most wireless devices just give up. If they can see the network they seem unable to maintain a link.

When I fitted out the shack I was forced to find a solution. I could have gone out and got a wireless booster to fill the blackspot, but as I had a collection of various wireless routers/access points I investigated possible solutions that didn’t involve any expenditure. I made the assumption that the superior antennas and design of the RF circuits in the access points would overcome the range issue. I was sort of correct and in the end I managed to get a Netgear WNR2000 configured using WDS to connect to the main house wireless.

Sadly the WNR2000 is quite frankly rubbish and often needs to be rebooted to get the link established, when it works it is great but too often it doesn’t! The other major issue was the implementation of WDS will only work with WEP encryption.

WEP is potentially insecure, I was getting more and more concerned about this so when I finally deprecated the last remaining WEP only devices in the house I have switched to WPA, ironically I had hoped to use WPA2 but alas some devices are WPA only!

Doing this has broken the shack network so I was back to square one. During the recent forced clearout I found a forgotten Buffalo router, mind you looking back you can see why I had forgotten it.

Have aquired a Buffalo AP and frankly it is a total piece of shit, shit setup & admin interface and has just forgotten the admin password!
— Andrew Garratt M6GTG (@nerdsville) November 27, 2009

A quick check and joy of joy it turned out to be a WHR-HP-G54, a device supported by the Tomato firmware, so was duly flashed up to version 1.28

I have now got it setup as a Wireless Ethernet Bridge and seems to be working well (I may have been a bit harsh on Twitter back in 2009!) and seems more importantly to be relatively RF quiet compared to the Netgear WNR2000 A good result!

Now I have some connectivity should make next weeks 144MHz UKAC contest a little easier, if I can the 2m antenna sorted and work out how to use the logging program.

Oh and the picture at the top? From South Park “Over Logging (or The Day the Internet Stood Still)“a classic episode!

One thought on “Wireless Woes

  1. Ah yes! I had one of those Buffalo access points that didn't like certain admin passwords and would lock you out, forcing a hard reset.

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*
Website