My WRT54G has become noisy!

I haven’t done much ‘radio stuff’ over the last few weeks due to work/family commitments and holidays but when I have found time I have been exasperated by huge levels of interference all across the HF/VHF bands which has suddenly appeared. Manifesting itself as huge regular bands of hash across most of the spectrum (as pictured below)

I assumed that a neighbour had purchased some new electronic device that was responsible. However last night I decided to go around the house again just in case, and discovered my ancient Linksys WRT54G router was the source.

I have had issues with QRM before and I was aware that this router was responsible for some noise in the VHF bands, but I had mitigated this by replacing all the network cables with brand new properly shielded network cables (screened shielded twisted pair) and ferrite clamps. This noise is something new and appears even with the network cables unplugged.

I naturally assumed it was the PSU as poor quality switch-mode power supplies used by most peripherals can be sources of interference, but interestingly the PSU for this router is actually a huge linear type judging by its size, weight and the temperature it runs at. I did try another compatible supply with the same results.  

Doing a Google search shows these routers seem to have a reputation for being RF noisy, but until now I haven’t had any real issue on HF.

Due to my ISP upgrading the network I got a Virginmedia SuperHub last year but was forced to put it into ‘modem’ mode and use my existing WRT54G after struggling to configure it. I couldn’t find anyway to configure the LAN to use the correct subnet (it kept defaulting to 192.168.0.1-255) never mind configuring the port forwarding and wireless access! The GUI and firmware was atrocious and I refused to go around reconfiguring all my devices. Maybe I might have to swallow my pride…

Leave a Reply

Your email address will not be published. Required fields are marked *

*
*
Website